Issue with python 3.3

Issue with python 3.3

Postby amit007 » Mon Jan 20, 2014 8:30 pm

Hi All , Could you please help me to solve below error while starting my pyramid framework project ?

Code: Select all
(v_env_testmvc_cmd) c:\Python33\Scripts>pserve.exe MyProject\development.ini --r
Traceback (most recent call last):
  File "c:\Python33\Scripts\", line 9, in <module>
    load_entry_point('pyramid==1.5a3', 'console_scripts', 'pserve')()
  File "c:\Python33\lib\site-packages\distribute-0.6.49-py3.3.egg\pkg_resources.
py", line 345, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "c:\Python33\lib\site-packages\distribute-0.6.49-py3.3.egg\pkg_resources.
py", line 2382, in load_entry_point
    return ep.load()
  File "c:\Python33\lib\site-packages\distribute-0.6.49-py3.3.egg\pkg_resources.
py", line 2088, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "c:\Python33\lib\site-packages\pyramid-1.5a3-py3.3.egg\pyramid\scripts\ps", line 31, in <module>
    from pyramid.paster import setup_logging
  File "c:\Python33\lib\site-packages\pyramid-1.5a3-py3.3.egg\pyramid\"
, line 10, in <module>
    from pyramid.scripting import prepare
  File "c:\Python33\lib\site-packages\pyramid-1.5a3-py3.3.egg\pyramid\scripting.
py", line 1, in <module>
    from pyramid.config import global_registries
  File "c:\Python33\lib\site-packages\pyramid-1.5a3-py3.3.egg\pyramid\config\__i", line 9, in <module>
    from webob.exc import WSGIHTTPException as WebobWSGIHTTPException
  File "c:\Python33\lib\site-packages\webob-1.3.1-py3.3.egg\webob\", line
1134, in <module>
    from paste import httpexceptions
  File "c:\Python33\lib\site-packages\paste-\paste\httpexceptio", line 77, in <module>
    from paste.wsgilib import catch_errors_app
  File "c:\Python33\lib\site-packages\paste-\paste\",
 line 135
    raise got_exc[0], got_exc[1], got_exc[2]
SyntaxError: invalid syntax

Could you please help me to solve all this errors ?
Last edited by stranac on Mon Jan 20, 2014 8:50 pm, edited 3 times in total.
Reason: Added code tags. Locked.
Posts: 1
Joined: Mon Jan 20, 2014 8:26 pm

Return to Web Development

Who is online

Users browsing this forum: No registered users and 1 guest