Python Configuration / Setup

This is the place for queries that don't fit in any of the other categories.

Python Configuration / Setup

Postby Terra » Mon Sep 19, 2016 3:29 am

Hi Folks,

I have been battling with some python version issues all day today, and I am a total loss. I am relatively new to Python and Linux, so apologies if this is a simple question.

Recently I downloaded the Oracle Big Data Lite Virtualbox stack. The stack has Python 2.6 installed, however I need to download Caravel which requires 2.7.x With that in mind I did installed it on my virtual machine:

Code: Select all
Python 2.7.11 (default, Sep 18 2016, 21:51:09)
[GCC 4.4.7 20120313 (Red Hat 4.4.7-17)] on linux2


Seems to be working ok.

Now when I try and run a pip request to get Caravel, for some reason all the libraries are going into the 2.6 version:

Code: Select all
[oracle@bigdatalite home]$ sudo pip install caravel
DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6
Requirement already satisfied (use --upgrade to upgrade): caravel in /usr/lib/python2.6/site-packages
Requirement already satisfied (use --upgrade to upgrade): babel==2.3.4 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): cryptography==1.1.1 in /usr/lib64/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): flask-appbuilder==1.7.1 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): Flask-BabelPkg==0.9.6 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): flask-cache==0.13.1 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): flask-migrate==1.5.1 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): flask-script==2.0.5 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): flask-testing==0.5.0 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): humanize==0.5.1 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): gunicorn==19.6.0 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): markdown==2.6.6 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): pandas==0.18.1 in /usr/lib64/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): parsedatetime==2.0.0 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): pydruid==0.3.0 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): python-dateutil==2.5.3 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): requests==2.10.0 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): simplejson==3.8.2 in /usr/lib64/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): sqlalchemy==1.0.13 in /usr/lib64/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): sqlalchemy-utils==0.32.7 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): sqlparse==0.1.19 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): werkzeug==0.11.10 in /usr/lib/python2.6/site-packages (from caravel)
Requirement already satisfied (use --upgrade to upgrade): pytz>=0a in /usr/lib/python2.6/site-packages (from babel==2.3.4->caravel)
Requirement already satisfied (use --upgrade to upgrade): idna>=2.0 in /usr/lib/python2.6/site-packages (from cryptography==1.1.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): pyasn1>=0.1.8 in /usr/lib/python2.6/site-packages (from cryptography==1.1.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): six>=1.4.1 in /usr/lib/python2.6/site-packages (from cryptography==1.1.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): setuptools in /usr/lib/python2.6/site-packages (from cryptography==1.1.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): enum34 in /usr/lib/python2.6/site-packages (from cryptography==1.1.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): ipaddress in /usr/lib/python2.6/site-packages (from cryptography==1.1.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): cffi>=1.1.0 in /usr/lib64/python2.6/site-packages (from cryptography==1.1.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): colorama>=0.3 in /usr/lib/python2.6/site-packages (from flask-appbuilder==1.7.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): click>=3.0 in /usr/lib/python2.6/site-packages (from flask-appbuilder==1.7.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): Flask>=0.10 in /usr/lib/python2.6/site-packages (from flask-appbuilder==1.7.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): Flask-Login==0.2.11 in /usr/lib/python2.6/site-packages (from flask-appbuilder==1.7.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): Flask-OpenID>=1.1.0 in /usr/lib/python2.6/site-packages (from flask-appbuilder==1.7.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): Flask-SQLAlchemy==2.0 in /usr/lib/python2.6/site-packages (from flask-appbuilder==1.7.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): Flask-WTF>=0.9.1 in /usr/lib/python2.6/site-packages (from flask-appbuilder==1.7.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): speaklater>=1.2 in /usr/lib/python2.6/site-packages (from Flask-BabelPkg==0.9.6->caravel)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.5 in /usr/lib/python2.6/site-packages (from Flask-BabelPkg==0.9.6->caravel)
Requirement already satisfied (use --upgrade to upgrade): alembic>=0.6 in /usr/lib/python2.6/site-packages (from flask-migrate==1.5.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): numpy>=1.7.0 in /usr/lib64/python2.6/site-packages (from pandas==0.18.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): pycparser in /usr/lib/python2.6/site-packages (from cffi>=1.1.0->cryptography==1.1.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.21 in /usr/lib/python2.6/site-packages (from Flask>=0.10->flask-appbuilder==1.7.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): python-openid>=2.0 in /usr/lib/python2.6/site-packages (from Flask-OpenID>=1.1.0->flask-appbuilder==1.7.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): WTForms in /usr/lib/python2.6/site-packages (from Flask-WTF>=0.9.1->flask-appbuilder==1.7.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): MarkupSafe in /usr/lib64/python2.6/site-packages (from Jinja2>=2.5->Flask-BabelPkg==0.9.6->caravel)
Requirement already satisfied (use --upgrade to upgrade): Mako in /usr/lib/python2.6/site-packages (from alembic>=0.6->flask-migrate==1.5.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): python-editor>=0.3 in /usr/lib/python2.6/site-packages (from alembic>=0.6->flask-migrate==1.5.1->caravel)
Requirement already satisfied (use --upgrade to upgrade): ordereddict>=1.1 in /usr/lib64/python2.6/site-packages (from WTForms->Flask-WTF>=0.9.1->flask-appbuilder==1.7.1->caravel)
[oracle@bigdatalite home]$


I have no idea why this is happening, can anyone help shed some light on this?

Thanks,

T.
Last edited by micseydel on Mon Sep 19, 2016 4:42 am, edited 1 time in total.
Reason: Initial post lock.
Terra
 
Posts: 1
Joined: Mon Sep 19, 2016 3:19 am

Return to General Coding Help

Who is online

Users browsing this forum: Google [Bot] and 1 guest