Basic TKinter error..HELP PLEASE

Post here if you need help with creating a Graphical User Interface in Python.

Basic TKinter error..HELP PLEASE

Postby marcofgodai » Mon Jun 17, 2013 8:52 pm

Hello,

I'm new to the world of coding, but I want to make basic GUI's for Autodesk Maya 2013 (and potentially Motionbuilder 2013). I use maya 2012-2014 just fyi in case that helps anyone.

I am running a MacBook Pro, Intel i5, OSX 10.6.8

I recently installed Python 2.7.5 (and 3.3 just as backup). I plan to use 2.7.5.
I downloaded the right python for my machine.

When I open maya, or the python shell and try to import Tkinter, i get the following error.

Code: Select all
import Tkinter

# Error: ImportError: dlopen(/Applications/Autodesk/maya2013/Maya.app/Contents/Frameworks/Python.framework/Versions/Current/lib/python2.6/lib-dynload/_tkinter.so, 2): no suitable image found.  Did find:
   /Applications/Autodesk/maya2013/Maya.app/Contents/Frameworks/Python.framework/Versions/Current/lib/python2.6/lib-dynload/_tkinter.so: mach-o, but wrong architecture #


Anyone know what to do? I've been reading about all these additional pieces and resetting python paths etc etc, but is there a CLEAR and CONCISE answer of how to solve this?
Any help is great help,

Thanks
M
marcofgodai
 
Posts: 3
Joined: Mon Jun 17, 2013 8:43 pm

Return to GUI

Who is online

Users browsing this forum: No registered users and 5 guests